**TheNebula**

Formerly 'Licker69'
Jan 3, 2019
52
8
I can't repair the radiator, if I click on it nothing happens and I tried all my items on it.

I'm done 3 of the 4 repair steps for the elevator but I can't do step 1, the wires are there but I don't have the shovel to dig. If I talk to Simon (he has the shovel) he asks for help which I can't give him despite having all 8 pieces of brush now. If I check with Andy using the pickaxe he just offers to let me dig and I say no. I can't get the pickaxe to get the shovel to dig the hole... anyone have any idea what I'm doing wrong?
Check the crystal ball , if i remember correctly after setting things up in the woods you need to go talk to Elizabeth after she been listening to music for a while and get a scene . you can go pick up the shovel again later when you caught the dude.
You need to find the old radiator piece to repair that radiator not other item will work .
 
  • Like
Reactions: Canto Forte

Ikariusrb

Member
Mar 21, 2018
80
42
Just picked this up and played through it. Not sure how you post a review specifically, so dropping this here, I can paste it into a review assuming I figure that out.

First off, this game represents the very best use of RPGmaker I've ever seen. The author has done a stunning job of putting nice frosting on the RPGmaker-provided interface to make this game feel like it's own thing, and not like every other RPGmaker game out there. Scenes and transitions play out smoothly, without layer-change funkiness, and effects- both visual and audio are very well done. A+ job on the UI/engine work.

The modeling is excellent, and there is a ton of content. And kudos for not making every woman in the game an F+ cup. Thank you.

This game also features what I believe to be the best fluid modeling I've ever seen in a smut game. Either the creator invested amazing effort in drawing in the fluid, or they used (and spent the time to learn) some fluid modeling software that produces results which absolutely rock the house compared to anything I've seen in other smut games.

On the other hand, the gameplay is exceedingly linear. You're playing through a story, the story is set, and you'll get relationship upgrades with the women only by progressing the story, in the order that the creator decided you'd get them. I understand the choice, I just don't love it. Upgrading relationship levels unlocks "play" scenes (there are a TON of them) which can be triggered pretty much anytime, so that is an excellent feature. The story itself is somewhere between decent and good. It's not bad, it's not amazing, but it works alright, and it scores some points for creativity- MC hasn't just moved in with 3 beautiful women yadda yadda.

Saving my one big complaint for last. Unfortunately, the majority of the women featured in the game have.... distinctly unhappy/angry faces, essentially all the time. Even during sex scenes, they don't look... happy. Of course, their characters aren't particularly happy as written- they seem to have substantial dissatisfaction with their lives, but this is a smut game. I'd enjoy it a lot more if they appeared to be enjoying it more.
 

urhen225

New Member
Jun 25, 2019
7
1
i am stuck.. i need the second wheel which is in the forest, but i cannot get to it cause i need a second hook (have the second rope already), and i need the second wing for the angel statue. and the 8th green thing for the door for the second girl.
everything else was okay till now but these 4 things annoy me atm.

help pls

Edit: angel wing problem solved thx to Donnie Brasco . Still need the 2nd hook, wheel and 8th chip-door-thingy
Once you get all chips, you will afterwards get the second hook. There are posts with images of the locations of all 8 chips in this thread.
 
  • Like
Reactions: Canto Forte

dahobo

Member
Jul 24, 2018
86
52
Yes, but you have to copy them around each new update; the other method just recognizes the older saves and lets you continue from there.

Anyway, i'm sorry for the delay but 3GB take a little time to be uploaded and now here is the link for the unofficial Lust Epidemic v77071 for Mac (previous saves work, the version indication on the title window is correct this time :) ):

I was able to continue the story without any issue, so I think you should have no problems either but if it happens let me know.

Have fun!
Thanks again for doing this. However, i'm getting the error "The application Game can't be opened". Any ideas what i can try to get my Mac to accept your genius? ^_^
 
4.70 star(s) 69 Votes