Man of the House Troubleshooting Help

edtorious

New Member
Aug 29, 2018
12
1
I'm not a Mac user, but this should help explain it.
thanks! that helps. now on another step, it says to cd to the location of winetricks, where can i find winetricks? I don't recall getting or installing winetricks?
 

goobdoob

Well-Known Member
Modder
Respected User
Dec 17, 2017
4,180
4,907
You know, what the problem here is?
View attachment 280444
Wine Staging 3.19 gives me this:
WINEPREFIX=~/.moth wine "man of the house.exe"
wine: invalid directory ~/.moth in WINEPREFIX: not an absolute path

Maybe that's a different message for the same error, changed in 4.x? Try an absolute path.

thanks! that helps. now on another step, it says to cd to the location of winetricks, where can i find winetricks? I don't recall getting or installing winetricks?
@Sycho the link to winetricks in the installation guide isn't a link. It should be this:

Edtorious, save that page as a file called "winetricks".
 
  • Like
Reactions: edtorious

Sycho

Well-Known Member
Respected User
May 9, 2018
1,813
1,673
Wine Staging 3.19 gives me this:
WINEPREFIX=~/.moth wine "man of the house.exe"
wine: invalid directory ~/.moth in WINEPREFIX: not an absolute path

Maybe that's a different message for the same error, changed in 4.x? Try an absolute path.


@Sycho the link to winetricks in the installation guide isn't a link. It should be this:

Edtorious, save that page as a file called "winetricks".
I'm trying to locate it now in under the Mac installation guide, but I'm not seeing it (the link that is - or the incorrect link) unless I'm overlooking the obvious?

EDIT

I added a link to it on number 5 in the guide.

EDIT
Minor change in revision (see second image).
 

Attachments

  • Like
Reactions: edtorious

goobdoob

Well-Known Member
Modder
Respected User
Dec 17, 2017
4,180
4,907
I'm trying to locate it now in under the Mac installation guide, but I'm not seeing it (the link that is - or the incorrect link) unless I'm overlooking the obvious?

EDIT

I added a link to it on number 5 in the guide.

EDIT
Minor change in revision (see second image).
Great, thanks!
 
  • Like
Reactions: Sycho

edtorious

New Member
Aug 29, 2018
12
1
Thanks for the help @goobdoob and @Sycho it works now but the only thing I can't figure out is the Mac command script to launch MotH under wine step. I downloaded the script and unzipped it to my desktop. This is the part I do not understand (You will need to edit it with the location of Wine Staging, or use Wine Staging 3.19 and put it in /Applications (the default installation location)). Can someone clarify this for me? Thanks.
 
  • Like
Reactions: Sycho

goobdoob

Well-Known Member
Modder
Respected User
Dec 17, 2017
4,180
4,907
Thanks for the help @goobdoob and @Sycho it works now but the only thing I can't figure out is the Mac command script to launch MotH under wine step. I downloaded the script and unzipped it to my desktop. This is the part I do not understand (You will need to edit it with the location of Wine Staging, or use Wine Staging 3.19 and put it in /Applications (the default installation location)). Can someone clarify this for me? Thanks.
The script is a text file. It assumes a certain location for Wine:
wine_install="/Applications/Wine Staging 3.19.app"

If that's not where your Wine app is, change that line to be the path and filename of your Wine app.

The script should sit in the MotH folder, right next to the .exe.
 

cold_arctus

Well-Known Member
Sep 25, 2018
1,765
2,068
Wine Staging 3.19 gives me this:
WINEPREFIX=~/.moth wine "man of the house.exe"
wine: invalid directory ~/.moth in WINEPREFIX: not an absolute path
You get this message, because you do not have a (new) Wineprefix named ".moth" in your $home directory.

Maybe that's a different message for the same error, changed in 4.x? Try an absolute path.
We tried 3.19 staging and 4.0 as well. He gets the same messages even with the default config.

Do you have a terminal command which can delete wine with all his folders and files on a Mac?

@Sycho @goobdoob
winetricks.png
You can either save it as file named winetricks or install it via Homebrew.

Using Homebrew (brew install winetricks) a file named winetricks will be saved in usr/local (or was it usr/bin :unsure: - really don't know where it is on a Mac!).
 

goobdoob

Well-Known Member
Modder
Respected User
Dec 17, 2017
4,180
4,907
You get this message, because you do not have a (new) Wineprefix named ".moth" in your $home directory.



We tried 3.19 staging and 4.0 as well. He gets the same messages even with the default config.

Do you have a terminal command which can delete wine with all his folders and files on a Mac?

@Sycho @goobdoob
View attachment 280920
You can either save it as file named winetricks or install it via Homebrew.

Using Homebrew (brew install winetricks) a file named winetricks will be saved in usr/local (or was it usr/bin :unsure: - really don't know where it is on a Mac!).
There's this secret command to delete stuff called "rm" :). Delete the app and the wine config directory separately; nothing like the Linux package management stuff. There are installers/uninstallers, but they're not used for Wine. OK, Wine can use an installer, but short answer is no.

Using an absolute path for WINEPREFIX worked for me. I was able to launch MotH; it created the new prefix in ~/.moth. Try $HOME/.moth instead of ~/.moth. Of course, it didn't have corefonts or the video stuff since I didn't install those, but MotH ran.

I haven't used brew to install winetricks, so I don't know what that does.
 

Johnny6

Member
Feb 18, 2018
76
68
You're welcome. Whenever you're ready, let me know.
It finally working and by accident. Yesterday I watched hockey game and attach my laptop to TV with HDMI cable. At the break I check whats new on F95 and saw Moth so I decided to give it the last chance, I run it as an admin, hockey game went silent and the game start. After hockey match I removed the cable and try the game and get same errors when I last time asking help. Attach HDMI again and the game runs perfectly, during the game I can remove the cable and it works fine. Now I'm thinkig why I can't start game without the cable.
 

cold_arctus

Well-Known Member
Sep 25, 2018
1,765
2,068
Attach HDMI again and the game runs perfectly, during the game I can remove the cable and it works fine. Now I'm thinkig why I can't start game without the cable.
This sounds like a configuration or driver problem to me. Recently we got a few people with Gaming Laptops and AMD Graphics Card, who had problems to play the game.

Pls. share more information about your System etc.
 

Johnny6

Member
Feb 18, 2018
76
68
This sounds like a configuration or driver problem to me. Recently we got a few people with Gaming Laptops and AMD Graphics Card, who had problems to play the game.

Pls. share more information about your System etc.
I have Lenovo G510, core i7-4700 cpu 2.40ghz, 6gt ram, intel hd graphics 4600
 

BiggusDikkus

Active Member
Jan 5, 2018
144
43
I have searched for any help on this but I can't seem to run the animations. Linux Mint 19.1 via WINE.