- Jun 10, 2017
- 10,845
- 15,965
Oh My Fucking God...
ApeStudios your game is not bad and interesting, but if you don't want to end being totally overwhelmed, you should really take the time to rethink all your code, and especially the way you handle the game state. 24273 variables is more than clearly way too many, especially when it's variables like "numbervariable1008", "thisvariable661" or "nikkiemergencygallerythingenabled20".
You would save you a lot of time and energy if, among other things, you used classes instead of having 49 times the same series of 173 variables, and if you gave more significant names to the variables.
And the code is uselessly over complicated. All the:
could perfectly directly be:
incidentally, "
You don't need so many Tooltip objects. In fact you need none since the
Same for the randomized values. By default "randomchat" could perfectly use only one and in real time:
But in fact the whole screen could perfectly be four lines long and use a small two dimension list:
The whole "vipchatofkissing" could perfectly be an
But of course the best approach would be to follow the steps of "randomchat" and have a a four line screen with a small two dimension list:
And so on...
By over complicating the code, you:
- Impose yourself an useless amount of stress
- Uselessly expand the time you need to develop the game
- Drastically increase the risk of bugs due to a typo
- Significantly reduce the chance that someone discover the bug early
- Make it more difficult to come back on a code that you already wrote and understand what it do
- Make it more difficult to make a small change or a small correction
- Significantly increase the time lost passing from a part of the code to another
ApeStudios your game is not bad and interesting, but if you don't want to end being totally overwhelmed, you should really take the time to rethink all your code, and especially the way you handle the game state. 24273 variables is more than clearly way too many, especially when it's variables like "numbervariable1008", "thisvariable661" or "nikkiemergencygallerythingenabled20".
You would save you a lot of time and energy if, among other things, you used classes instead of having 49 times the same series of 173 variables, and if you gave more significant names to the variables.
And the code is uselessly over complicated. All the:
Python:
init:
image thumb4:
im.MatrixColor("images/gallerythumbs/avashoweringthumb.jpg", im.matrix.brightness(.2))
Python:
imagebutton:
idle "images/gallerythumbs/avashoweringthumb.jpg"
hover im.MatrixColor("images/gallerythumbs/avashoweringthumb.jpg", im.matrix.brightness(.2))
You must be registered to see the links
", what mean that you don't need the init:
part, and even less to declare it before every single one of them.You don't need so many Tooltip objects. In fact you need none since the
You must be registered to see the links
property permit you to pass whatever you want as value, including both the text to display and the position where it should be displayed:You don't have permission to view the spoiler content.
Log in or register now.
Same for the randomized values. By default "randomchat" could perfectly use only one and in real time:
You don't have permission to view the spoiler content.
Log in or register now.
You don't have permission to view the spoiler content.
Log in or register now.
The whole "vipchatofkissing" could perfectly be an
You must be registered to see the links
image:You don't have permission to view the spoiler content.
Log in or register now.
You don't have permission to view the spoiler content.
Log in or register now.
And so on...
By over complicating the code, you:
- Impose yourself an useless amount of stress
- Uselessly expand the time you need to develop the game
- Drastically increase the risk of bugs due to a typo
- Significantly reduce the chance that someone discover the bug early
- Make it more difficult to come back on a code that you already wrote and understand what it do
- Make it more difficult to make a small change or a small correction
- Significantly increase the time lost passing from a part of the code to another